Du bist nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: WebStyleBoard. Falls dies dein erster Besuch auf dieser Seite ist, lies bitte die Hilfe durch. Dort wird dir die Bedienung dieser Seite näher erläutert. Darüber hinaus solltest du dich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutze das Registrierungsformular, um dich zu registrieren oder informiere dich ausführlich über den Registrierungsvorgang. Falls du dich bereits zu einem früheren Zeitpunkt registriert hast, kannst du dich hier anmelden.

1

Freitag, 4. Januar 2008, 06:11

fsockopen() und niemals "false" ??

hilöchen

Wie in diesem Thread angesprochen wurde, leitete die Startseite vom WSB desöfteren auf die Startseite des Hoster um. Mir ist das selber nie so wirklich aufgefallen, weil ich immer direkt aufs Portal und so ...

Da dieses Problem nur auf der Startseite auftauchte, war die Ursache relativ schnell gefunden. Am Ende der Seite gibt es 3 Textlinks, welche über fsockopen() eingebunden wurden. Sobald nun die Datei, von welcher die Textlinks geholt werden, nicht erreichbar war tat fsockopen() etwas eigenartiges: statt "false" und einen Fehler zurückzugeben bekommt man die Startseite meines Hosters zu sehen. Wenn also die gewünschte Seite nicht vorhanden ist, bekommt mal leider ein "true", aber mit den Daten der falschen Seite.

hier hab ich mal ne Testdatei hochgeladen, auf welcher das Problem deutlich wird.
http://www.webstyleboard.de/main_test.php
da es die "nicht-existierende-domain.de" wirklich nicht gibt, müsste ich eigentlich eine Fehlermeldung bekommen ...

Irgendwer ne Idee wie man das beheben kann bzw. welche (Server?)Einstellung dafür verantwortlich ist?

TNS
Signatur von »TheNobody Style«

2

Sonntag, 6. Januar 2008, 12:25

Eine Lösung nicht ganz, aber du könntest doch mal beim Hoster nachfragen wieso er das macht?
Signatur von »oop1« _________

3

Sonntag, 6. Januar 2008, 17:04

jupp ... auf die Idee bin ich "04.01.2008 06:11" - total übermüdet - nicht mehr gekommen :tired:
mach ich aber mal :)
Signatur von »TheNobody Style«

4

Freitag, 11. Januar 2008, 22:55

Gibt es schon Neuigkeiten in dieser Angelegenheit seitens Prosite?

Und liegt die Datei, die nicht gefunden wird unter einer Domain die auch von Prosite gehostet wird?
Signatur von »LapisInfernalis« Eine Milde Gabe...

Der Horizont vieler Menschen ist ein Kreis mit dem Radius Null - und das nennen sie ihren Standpunkt.

Albert Einstein (1879-1955)

A common mistake people make when trying to design something completely foolproof is to underestimate the ingenuity of complete fools.
Douglas Adams (1952-2001)

5

Samstag, 12. Januar 2008, 06:55

ja und nein (die Domain gibt es ja auch gar nicht, ausser du hast sie dir registriert um damit nen haufen Geld zu machen :P )

ja es gibt Neuigkeiten - soweit ich es verstanden (was sehr relativ ist :suspicious: ) habe werden dabei die Nameserver abgefragt und wenn die den Domainnamen nicht kennen wird hier der Defaulteintrag, also prosite.de, zurückgegeben. Mir wurde aber versichert, dass dies demnächst geändert wird

sollte also jemand gelangweilt sein und den technische Ablauf von fsockopen() mal einfach und idiotensicher mit verklickern wollen - nur zu :)

TNS
Signatur von »TheNobody Style«