Du bist nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: WebStyleBoard. Falls dies dein erster Besuch auf dieser Seite ist, lies bitte die Hilfe durch. Dort wird dir die Bedienung dieser Seite näher erläutert. Darüber hinaus solltest du dich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutze das Registrierungsformular, um dich zu registrieren oder informiere dich ausführlich über den Registrierungsvorgang. Falls du dich bereits zu einem früheren Zeitpunkt registriert hast, kannst du dich hier anmelden.

1

Montag, 17. November 2008, 18:24

Codesatz für swf-Film im web

Hallo,
ich verzweifle bald an einer sicherlich popligen Kleinigkeit und hoffe hier Erbarmen zu finden:
Es soll auf meiner Website mithilfe eines Buttons ein SWF-Film geladen und abgespielt werden. Folgenden Code verwendete ich:
on(release) {mc_00loadMovie("http://www.meineHP.de/meinFilm.swf","stage");}
Der Film kommt aber nicht. Was habe ich da falsch gemacht?
Danke im Voraus für deine Hilfe!
Toni

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »toni-s« (17. November 2008, 19:32)


2

Montag, 17. November 2008, 20:49

Hallo Toni,

kurz ein paar Fragen:

mc_00

Ist das der MovieClip, auf welchem die on(release)-Anweisungen liegen?

stage

Ist das der MC in welchen der Film geladen werden soll?

Spontan fällt mir auf, dass zwischen mc_00 und loadMovie fehlt ein . (Punkt). Außerdem solltest Du die SWF-Datei besser relativ einbinden.

Soweit erst einmal auf die Schnelle!

Greetings

Lapis
Signatur von »LapisInfernalis« Eine Milde Gabe...

Der Horizont vieler Menschen ist ein Kreis mit dem Radius Null - und das nennen sie ihren Standpunkt.

Albert Einstein (1879-1955)

A common mistake people make when trying to design something completely foolproof is to underestimate the ingenuity of complete fools.
Douglas Adams (1952-2001)

3

Montag, 17. November 2008, 22:07

Codesatz für swf-Film im web

Hallo Lapis,
vielen Dank für deine Antwort!
Zunächst zu deinen Fragen:
Es stimmt, "mc_00" ist ein Movieclip-Instance, die - soweit ich das nachvollziehen kann - vom "btn_00" automatisch generiert wurde. Die Bezeichnung "btn_00" ist, glaube ich, ebenfalls von Flash MX automatisch generiert worden. Ich selber war es jedenfalls nicht.

Syntax-Änderung:
Ich habe - wie du vorschlugst - den Punkt eingesetzt. Der String sieht so aus:
on(release) {mc_00.loadMovie("http://www.meineHP.de/meinFilm.swf","stage");}

Da der Film trotzdem nicht anläuft, wird es wohl daran liegen, dass ich den Film noch nicht "relativ" eingebunden haben. Es müsste ja wohl "absolut" sein.
Kleine Zwischenfrage: Was meinst du damit? :dizzy:
Bin neugierig auf deine Antwort.
Grüße,
Toni

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »toni-s« (17. November 2008, 22:09)