Du bist nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: WebStyleBoard. Falls dies dein erster Besuch auf dieser Seite ist, lies bitte die Hilfe durch. Dort wird dir die Bedienung dieser Seite näher erläutert. Darüber hinaus solltest du dich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutze das Registrierungsformular, um dich zu registrieren oder informiere dich ausführlich über den Registrierungsvorgang. Falls du dich bereits zu einem früheren Zeitpunkt registriert hast, kannst du dich hier anmelden.

1

Dienstag, 12. Juli 2005, 19:18

Noch ein Problem mit Preloader-Tutorial

Hi, es geht um dieses Tutorial.

Ich hab es gemacht und es funktioniert auch eigentlich einwandfrei, mit einer Einschränkung:
Die Flashdatei wird geladen, dann steht dort direkt 100% geladen, erst wenn die datei komplett geladen ist, vorher steht dort nicht. Erstes und zweites Frame hab ich den Preloader, wie in dem Tutorial. Im dritten Frame ist folgendes ActionScript:

Quellcode

1
2
3
4
Song = new Sound();
Song.attachSound("dumb");
Song.start();
stop();


Sound wird auch abgespielt, aber es wird der Preloader halt erst angezeigt, wenn die Datei schon vollständig geladen ist und das ist ja nicht sinn und zweck eines Preloaders.

Was kann ich machen? Ich bin eher Flash-Anfänger

Gruß
Teerow

2

Donnerstag, 14. Juli 2005, 08:31

Hi Teerow!

Zunächst einmal: Herzlich Willkommen auf dem WSB! Und Sorry für die lange Wartezeit... ;)

Zunächst solltest Du ausprobieren, ob der Preloader selbst funktioniert. Dafür erstellst Du am besten eine Kopie Deiner Datei, entfernst das ActionScript für die Sound-Wiedergabe und plazierst im dritten Frame einfach ein oder mehrere Bilder mit großer Datenmenge.

Dafür reicht es, wenn Du in einem Grafikprogramm Deiner Wahl ein paar große Bilder erstellst, und diese dann im dritten Frame plazierst.

Auf diese Weise kannst Du zunächst einmal ausschließen, ob es am Preloader selbst liegt, oder nicht.

Ein kleiner Tipp an Rande: Bei kleinen Dateien ist es oft schwierig, den Preloader online zu testen (Dank DSL... ;) ). Das ist aber auch gar nicht nötig. Nur für den Fall, dass Du es nicht schon wissen solltest:

Wenn Du Deinen Preloader testen möchtest, drückst Du in Flash einfach die Tastenkombination STRG + Eingabetaste. Dadurch wird eine Art Vorschau angezeigt. Nun kannst Du im Menü "Fehlersuche" eine Verbindungsgeschwindigkeit aussuchen, oder eine benutzerdefinierte Verbindungsgeschwindigkeit anlegen.

Wenn Du nun erneut STRG + Eingabetaste verwendest, wird der Film mit der ausgewählten Geschwindigkeit geladen. Auf diese Art kannst Du die Verwendung von Modems und ISDN simulieren und bequem Deine Preloader testen...
Signatur von »LapisInfernalis« Eine Milde Gabe...

Der Horizont vieler Menschen ist ein Kreis mit dem Radius Null - und das nennen sie ihren Standpunkt.

Albert Einstein (1879-1955)

A common mistake people make when trying to design something completely foolproof is to underestimate the ingenuity of complete fools.
Douglas Adams (1952-2001)

3

Sonntag, 17. Juli 2005, 14:52

Hi,

Danke für die Antwort. Ich hab den Preloader getestet. Er ist völlig in Ordnung. Das Problem lag daran, dass die Soundfilde im ersten Frame schon geladen wurde, sodass der Preloader erst angezeigt wurde, wenn die Datei geladen war, deshalb konnte es ja nicht funktionieren ^.^. Habs aba ja nu hinbekommen ;)

Aba danke für deine Hilfe ;)

Gruß
Teerow

4

Sonntag, 17. Juli 2005, 18:17

[q=teerow]Aba danke für deine Hilfe[/q]
Gern geschehen... Wenngleich ich ja nicht wirklich viel gemacht habe... :)

Und wenn Du wieder Probleme hast: Nicht verzagen! WSB fragen... :D
Signatur von »LapisInfernalis« Eine Milde Gabe...

Der Horizont vieler Menschen ist ein Kreis mit dem Radius Null - und das nennen sie ihren Standpunkt.

Albert Einstein (1879-1955)

A common mistake people make when trying to design something completely foolproof is to underestimate the ingenuity of complete fools.
Douglas Adams (1952-2001)