Du bist nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: WebStyleBoard. Falls dies dein erster Besuch auf dieser Seite ist, lies bitte die Hilfe durch. Dort wird dir die Bedienung dieser Seite näher erläutert. Darüber hinaus solltest du dich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutze das Registrierungsformular, um dich zu registrieren oder informiere dich ausführlich über den Registrierungsvorgang. Falls du dich bereits zu einem früheren Zeitpunkt registriert hast, kannst du dich hier anmelden.

1

Mittwoch, 29. Juni 2005, 16:53

RE: Preloader in % und Bytes für Flash MX

Hi,
das Tutorial für den Preloader ist sehr amüsant und didaktisch beschrieben, so dass sogar ich (!) mich daran wagte, es in meine Flash-Animation einzubauen. Aber das Ruckeln bei diesem Film (Textelemente, die ins Bild kommen) ist unverändert. Auf meiner Homepage laufen neben dieser auch noch andere, teils deutlich aufwändigere und längere Filme (Fotos). Doch diese laufen nahezu ruckelfrei. Was kann denn da falsch sein? Zur Info hier der Link zu meiner Homepage: http://www.stigloher.de

Systeminfos:
Mac OS X 10.3.9 (Panther), Flash MX

2

Mittwoch, 29. Juni 2005, 18:11

Hallo toni-s!

Erst einmal herzlich Willkommen an Board! ;)

[q=toni-s]Aber das Ruckeln bei diesem Film (Textelemente, die ins Bild kommen) ist unverändert.[/q]
Dieser Satz hat mich zunächst etwas verwirrt... Welches Ruckeln? Habe ich was verpasst? ;) Korrigiere mich, sollte ich mich irren:

Deine Animation ruckelt. Und Du hast gehofft, dass dies verschwindet, wenn Du einen Preloader in den Film einfügst, richtig?

Wenn dem so ist: Die Performance einer Animation hat nichts damit zu tun, ob Du einen Preloader verwendest, oder nicht... Der Preloader dient einzig und allein dem Zweck, dass jemand, der eine langsame Verbindung zum Internet hat, sieht das etwas passiert.

Ansonsten würde nämlich erst der Film abgespielt, wenn er komplett geladen ist. Doch dies kann, je nach Verbindungsart und Datenmenge, einen Augenblick dauern. Durch den Preloader wird die Ladephase auch nicht kürzer. Du machst sie lediglich für den Benutzer sichtbar. Er sieht, dass sich was tut, und er kann abschätzen, wann der Ladevorgang abgeschlossen ist.

Wenn die Wiedergabe Deines Filmes ruckelt, liegt dies - in der Regel - am Film selbst. Folgende Punkte solltest Du beachten:

- Wie groß ist die Datei? (Nicht wegen der Ladedauer, sondern der Größe der Komponenten)
- Bilder niemals in Flash skalieren, sondern immer in der richtigen Größe verwenden
- Bildgrößen auch möglichst nicht im Laufe einer Animation ändern
- Hast Du viele Schriftarten verwendet

Ich für meinen Teil kann bei der von Dir angesprochenen Animation kein Ruckeln feststellen. Mmmh... Hier mal ein paar Fragen, deren Beantwortung uns Deinem Problem näherbringen:

- Wie groß ist die fla-Datei
- Wie groß ist die swf-Datei
- Wieviele Bilder (JPEG, GIF usw.) verwendest Du?
- Welche Datenmenge haben diese?
- Wie sieht die Konfiguration des Rechners aus, auf dem es ruckelt?
Signatur von »LapisInfernalis« Eine Milde Gabe...

Der Horizont vieler Menschen ist ein Kreis mit dem Radius Null - und das nennen sie ihren Standpunkt.

Albert Einstein (1879-1955)

A common mistake people make when trying to design something completely foolproof is to underestimate the ingenuity of complete fools.
Douglas Adams (1952-2001)

3

Mittwoch, 29. Juni 2005, 19:17

ruckeln oder nicht ruckeln, das ist hier die Frage...

Hi Lapis,
danke für die schnelle Reaktion! Bevor ich zur Beantwortung deiner Fragen komme, eine genauere Definition meines "Ruckelproblems":
Ich habe auf meiner Homepage mehrere Flashfilme, die eigentlich alle ganz nett laufen. Hier geht es um die beiden Filme "Wir sind Dienstleister für" und "Das machen wir für Sie". Dort gibt es keine Bilder außer den Fonds, sonst nur 1 Schrift (Copperplate). An keiner Stelle werden Grafiken oder Schriften während des Laufs skaliert.

Jetzt zu deinen Fragen:
1. Die fla-Dateien haben ca. 2,5 MB
2. Die swf-Dateien haben ca. 56 KB und 70 KB
3. Es werden 5 Fondgrafiken verwendet, die genau auf die Fenstergröße angepasst sind (750x450 px). Vorlage dazu sind mit Photoshop web-optimierte JPGs mit max. 8 KB. Die Navigationsbuttons sind ebenfalls winzig klein. Alle verwendeten Grafiken sind auf die Endgröße erstellt.
4. Der verwendete Rechner ist zwar keine Rennsau, aber es sollte reichen: 800 MHz, 384 MB SD-RAM. Ich bearbeite damit oft Bilder mit zig Ebenen bis über 1 GB.
Ein Freund sagte mir, Macintoshrechner hätten Probleme mit Javascript. Mir ist das aber noch nirgens aufgefallen.
Die Systemfestplatte hat 40 GB, davon sind z.Zt. noch 6 GB frei.
Die Festplatte, auf der die Datenabgelegt sind, hat 80 GB, davon sind z.Zt. ca. 30 GB frei.

Ich kann mir eigentlich kaum vorstellen, dass mein Equipment wirklich so schwach ist, oder?
Ciao,
toni

4

Mittwoch, 29. Juni 2005, 20:34

Sooo... Ich habe mir mal die Freiheit genommen, einen eigenen Thread aus Deinem Beitrag zu machen, da es wohl weniger mit dem Preloader zu tun hat...

Denn das Ruckelproblem hast Du sowohl mit, also auch ohne Preloader, oder?

Also datenmengentechnisch sollte es keine Probleme geben. Die verwendeten Daten sind auch sehr durchdacht! Gratulation hierzu! :thumbsup:

Auch die Hardware sollte völlig ausreichend sein... Mal eine andere Frage: Mit wieviel Frames pro Sekunde läuft der Film? Standardmäßig laufen Flash-Filme im Web mit 12 Bildern pro Sekunde. Da ist ein Ruckeln nie ganz zu vermeiden.

Erhöhe mal die Anzahl der Bilder pro Sekunde auf 24 B/s. Läuft der Film dann besser?
Signatur von »LapisInfernalis« Eine Milde Gabe...

Der Horizont vieler Menschen ist ein Kreis mit dem Radius Null - und das nennen sie ihren Standpunkt.

Albert Einstein (1879-1955)

A common mistake people make when trying to design something completely foolproof is to underestimate the ingenuity of complete fools.
Douglas Adams (1952-2001)

5

Montag, 4. Juli 2005, 11:45

Ruckel ist nicht wegzukriegen

Hi Lapis,
ich bin noch ganz neu hier und kenne die Abläufe noch nicht so genau. Ich dachte nämlich, wenn auf meinen Beitrag eine Antwort käme, würde ich automatisch per eMail benachrichtigt werden. Oder gibts das doch und ich müsste dazu was einstellen?

Bevor ich die Hühner scheu mache, möchte ich das bei mir auftretende "Ruckeln" erst mal beschreiben:
Es ist nicht etwa wie ein zu langsam ablaufender Film, bei dem man die einzelnen Bilder sehen kann, sondern ein mehr oder weniger ungleichmäßiger Ablauf, etwa so: 3 s Go, dann 0,5 s Stopp, dann wieder 2 s Go, 0,3 s Stopp u.s.w. Soweit ich das erkennen kann, sind die Stop-and-Go-Perioden immer gleich, d.h., der Film sieht auf meinem Rechner immer gleich blöd aus. Zum Schluss noch die interessanteste Beobachtung: Der Fehler tritt bereits im Flash-Dokument auf.

Nun zur Beantwortung deiner Fragen bzw. Bemerkungen:
1. Ja, das Ruckeln ist unabhängig vom Preloader.
2. Danke für das große Lob! Da wird mein zerknülltes Selbstvertrauen wieder ein bisschen ausgebügelt. Im übrigen habe ich den Eindruck, du und dein Adminteam seid auch nicht gerade auf der Brennsuppe dahergeschwommen... ;-)
3. Bei genauer Prüfung der Frames stellte ich fest, dass ich bereits 25 fps eingestellt hatte. Und beim Versuch mit 12 fps hatte ich das Gefühl, das Ruckeln ist noch schlimmer.
4. Vielleicht hängt das Problem tatsächlich mit dem Mac-Betriebssystem zusammen (ich erwähnte bereits die Bemerkung eines Freundes diesbezüglich.
Dann habe ich noch einen Verdacht: Dieser Flash-Film besteht hauptsächlich aus Texten, die als "Grafik" umgewandelt werden. In meiner Homepage http://www.stigloher.de gibt es noch einen weiteren, viel aufwändigeren Film, aber mit Fotos. Dieser Film läuft einwandfrei. Ich schließe eben daraus, dass bei der Umwandlung der Fonts in "Grafik" etwas nicht so sauber läuft. Was meinst Du?

6

Montag, 4. Juli 2005, 12:05

[q=toni-s]Ich dachte nämlich, wenn auf meinen Beitrag eine Antwort käme, würde ich automatisch per eMail benachrichtigt werden. Oder gibts das doch und ich müsste dazu was einstellen?[/q]
Diese Funktion gibt es, ist aber standardmäßig deaktiviert. Wenn Du einen Thread erstellst, oder auf ein Posting antwortest, siehst Du unter dem Textfeld ein paar Kontrollkästchen. Einer davon lautet: "Benachrichtigung: Möchten Sie über weitere Antworten...".

Ein Häkchen an dieser Stelle informiert Dich wie gewünscht per Email... ;)

[q=toni-s]1. Ja, das Ruckeln ist unabhängig vom Preloader. [/q]
Gut. Das schränkt die Fehlersuche weiter ein...

[q=toni-s]2. Danke für das große Lob! Da wird mein zerknülltes Selbstvertrauen wieder ein bisschen ausgebügelt. Im übrigen habe ich den Eindruck, du und dein Adminteam seid auch nicht gerade auf der Brennsuppe dahergeschwommen... ;-)[/q]
Gern geschehen und vielen Dank meinerseits. ;) Brennsuppe? Was darf man sich denn bitte darunter vorstellen? :grin:

[q=toni-s]3. Bei genauer Prüfung der Frames stellte ich fest, dass ich bereits 25 fps eingestellt hatte. Und beim Versuch mit 12 fps hatte ich das Gefühl, das Ruckeln ist noch schlimmer.[/q]
Das kann sehr gut sein. Aber in jedem Fall liegt Dein Problem offensichtlich nicht an der Wiedergabegeschwindigkeit des Filmes. Ansonsten wäre das Ruckeln gleichmäßig und nicht nur an bestimmten Punkten.

[q=toni-s]4. Vielleicht hängt das Problem tatsächlich mit dem Mac-Betriebssystem zusammen (ich erwähnte bereits die Bemerkung eines Freundes diesbezüglich.[/q]
Diese Vermutung ist gar nicht so unbegründet. Eingans erwähntest Du dass, "Wir sind Dienstleister für" ruckelt. Das ist doch im Prinzip der erste Film nach dem Intro, oder?

Also bei mir (Win XP Pro) ruckelt da nix... :suspicious:

Leider habe ich in Sachen Flash keinerlei Mac-Erfahrungen. Zwar habe ich hier im Büro einen Mac stehen, konnte bisher aber erfolgreich einen großen Bogen um den Apfel machen... :cool:

[q=toni-s]Dann habe ich noch einen Verdacht: Dieser Flash-Film besteht hauptsächlich aus Texten, die als "Grafik" umgewandelt werden.[/q]
Verstehe... Doch wie bekommst Du den Text in das Grafikformat? Schreibst Du den Text in Flash, und wandelst ihn in ein Symbol um, oder schreibst Du den Text in einem anderen Programm (bei Dir naheliegenderweise Illustrator?) und exportierst ihn dann?
Signatur von »LapisInfernalis« Eine Milde Gabe...

Der Horizont vieler Menschen ist ein Kreis mit dem Radius Null - und das nennen sie ihren Standpunkt.

Albert Einstein (1879-1955)

A common mistake people make when trying to design something completely foolproof is to underestimate the ingenuity of complete fools.
Douglas Adams (1952-2001)

7

Montag, 4. Juli 2005, 12:40

Hi Lapis,
deine Antworten kommen ganz schön zügig! Ich dachte, da sitzen nur Leute, die sich gelegentlich im Forum umschauen. Nun habe ich schon den Eindruck, Euer Forum ist wie die Telekom-Hotline ständig besetzt - mit dem Unterschied, dass man bei Euch professionelle Antworten kriegt :-)

Das "Benachrichtigungs-Häkchen" ist bei mir angeklickt. Oder hast du das für mich inzwischen getan? Jedenfalls erhielt ich ein eMail, auf das ich hiermit antworte. Gerne würde ich es mit "Antwort zitieren" machen, aber ich durchschaue das System mit dem Fenster "Texteingabe" auf die Schnelle nicht.

Die Sache mit der Brennsuppe ist wohl rein bayerischer Natur, sprich umgangssprachlich. "Auf der Brennsuppn daherschwimmen" bedeutet keine Bildung, keine Ahnung, keine Erfahrung etc. Meine Erkenntnis ist eben, dass ihr nicht zu dieser Sorte gehört.

Der Clip "Wir sind Dienstleister" ist tatsächlich der erste Teil nach dem Intro. Am Ende schaltet er auf Clip2 "Wir machen für Sie".

Ich drückte mich missverständlich aus. Es sollte nicht "Grafik", sondern natürlich "Symbol" heißen. Die Texte sind also direkt in Flash MX erzeugt und nicht von woanders importiert.

Hilft dir das weiter?

8

Montag, 4. Juli 2005, 12:49

[q=toni-s]deine Antworten kommen ganz schön zügig![/q]
Ich bin <prollmode> Inhaber einer Agentur für digitale Mediengestaltung </prollmode> und bedingt durch die Selbstständigkeit eigentlich von morgens 8 bis abends 23 Uhr am Rechner und online...

Und da dass WSB meine Startseite ist... ;)

[q=toni-s]Ich drückte mich missverständlich aus. Es sollte nicht "Grafik", sondern natürlich "Symbol" heißen. Die Texte sind also direkt in Flash MX erzeugt und nicht von woanders importiert.[/q]
Ich würde nicht sagen, dass Du Dich missverständlich ausgedrückt hast. Gedacht habe ich mir das zwar schon, wollte es aber nur genau wissen, um etwaige Fehlerquellen ausschließen zu können...

[q=toni-s]Hilft dir das weiter?[/q]
Jepp... ;)

Eine andere Frage: Aus welchem Grund wandelst Du den Text in ein Grafiksymbol? Wenn ich das richtig sehe, besteht Deine Animation in erster Linie aus Bewegungstweens, oder? Diese kannst Du doch auch mit "normalem" Text machen.

Der Vorteil wäre, dass der Aufwand für Flash geringer ist, weil der Text intern immer noch Text bleibt und damit für Dich auch noch editierbar ist.

Was ich merkwürdig finde ist, dass der Film bei Dir offensichtlich ruckelt, mir jedoch nicht... Tue mir bitte mal einen Gefallen, und poste mal die Adresse, die direkt zur SWF-Datei des ersten betreffenden Filmes führt.
Signatur von »LapisInfernalis« Eine Milde Gabe...

Der Horizont vieler Menschen ist ein Kreis mit dem Radius Null - und das nennen sie ihren Standpunkt.

Albert Einstein (1879-1955)

A common mistake people make when trying to design something completely foolproof is to underestimate the ingenuity of complete fools.
Douglas Adams (1952-2001)

9

Montag, 4. Juli 2005, 18:06

Ruckelproblem

Hi Lapis,
sicher hast du schon mitgekriegt, dass wir gewisse Gemeinsamkeiten haben: Beide sind wir mehr oder weniger für die Werbung selbständig, beide haben wir keine Freizeit und beide nerven wir uns mit Problemen, die eigentlich Sache der Programmhersteller wären. Der Unterschied von uns beiden dürfte darin liegen, dass du dich mehr im Bereich Internet und ich mich im Bereich Printmedien aufhalte.
Dies ist auch der Grund, dass ich einige für dich total klare Dinge überhaupt nicht kapiere. Zum Beispiel der folgende Satz in deinem letzten Beitrag, die ich dich bitte, so ins Deutsche zu übersetzen, dass ich weiß, was du meinst:

Zitat

"Tue mir bitte mal einen Gefallen, und poste mal die Adresse, die direkt zur SWF-Datei des ersten betreffenden Filmes führt"


Die anderen Sätze hingegen habe ich verstanden. Da ich ja nur ein dummer Analphabet ohne jegliche Schulbildung bin http://www.webstyleboard.de/wsb/images/n…lies/dizzy.gif, tu ich einfach das, was mir mal ein nettes Mädchen beigebracht hat (sie hat Informatik studiert), nämlich alles in Symbole umzuwandeln, weil dann Bitmaps in Vektorgrafiken (Symbols) umgewandelt würden. Wahrscheinlich hat sie mir nicht explizit aufgetragen, die Schriften in Symbols umzuwandeln, denn Schriften sind ja schon Vektoren, gell? Zu meiner Ehrrettung: Ich hatte schon vor, statt der Schriften kleine Grafiken einzuladen und dann zu sehen, ob's noch immer ruckelt.

So, jetzt bin ich neugierig auf deine Übersetzung http://www.webstyleboard.de/wsb/images/n…ies/pleased.gif

10

Montag, 4. Juli 2005, 19:37

Hi Toni!

[q=toni-s]sicher hast du schon mitgekriegt, dass wir gewisse Gemeinsamkeiten haben: Beide sind wir mehr oder weniger für die Werbung selbständig, beide haben wir keine Freizeit und beide nerven wir uns mit Problemen, die eigentlich Sache der Programmhersteller wären.[/q]
Da hast Du Recht... Unsere Wurzeln sind sich nicht unähnlich. Seit mehr als mittlerweile acht Jahren bin ich in der Druckvorstufe (die ganze Zeit in einem Betrieb) tätig...

Im Herbst des vergangenen Jahres haben wir uns dann entschlossen, die Bereiche Print- und Digital-Medien einfach in zwei Unternehmen aufzuteilen.

Wobei unser DTP-Bereich sich weniger mit Foto- und Video-Produktion beschäftigt, als vielmehr um die reine Druckvorstufe. In der Hauptsache für die Werbeartikel- und Incentives-Branche...

[q=toni-s]Dies ist auch der Grund, dass ich einige für dich total klare Dinge überhaupt nicht kapiere. Zum Beispiel der folgende Satz in deinem letzten Beitrag, die ich dich bitte, so ins Deutsche zu übersetzen, dass ich weiß, was du meinst:
[q=LapisInfernalis]Tue mir bitte mal einen Gefallen, und poste mal die Adresse, die direkt zur SWF-Datei des ersten betreffenden Filmes führt[/q][/q]
Sorry. Ich neige leider dazu, Dinge nicht immer ganz Anfänger-verständlich auszudrücken... ;)

Hier mein zweiter Versuch:

Wenn Du die Flash-Datei in Deine HTML-Datei einbindest, sagst Du ja der HTML-Datei durch die Quellangabe, wo der Flash-Film zu finden ist. Diese Adresse meine ich. Der Hintergrund ist, dass man sich so die Datei alleine ansehen kann, und wir ganz sicher gehen, dass wir über die gleiche Datei sprechen.

Ich habe mir mal die Freiheit genommen, diesen Pfad herauszusuchen. Im vorliegenden Fall ist es:

http://www.stigloher.de/01-clip1-v02.swf

[q=toni-s]was mir mal ein nettes Mädchen beigebracht hat (sie hat Informatik studiert), nämlich alles in Symbole umzuwandeln, weil dann Bitmaps in Vektorgrafiken (Symbols) umgewandelt würden.[/q]
Da muss ich Dich leider enttäuschen, denn das stimmt so nicht. Ich meine damit nicht, dass das erwähnte Mädchen nicht nett ist... ;) Nur werden Bitmaps nicht automatisch vektorisiert, nur weil sie in ein Grafik-Symbol umgewandelt werden...

Um ein Bitmap zu vektorisieren muss man dieses auswählen und im Menü "Modifizieren" => "Bitmap nachzeichnen" auswählen... Die Einstellungsmöglichkeiten sind zwar anpassbar, aber das Ergebnis liegt Welten hinter einer manuellen Vektorisierung oder der Benutzung eines professionellen Trace-Programms.

[q=toni-s]Wahrscheinlich hat sie mir nicht explizit aufgetragen, die Schriften in Symbols umzuwandeln, denn Schriften sind ja schon Vektoren, gell?[/q]
Geeeenauuuu... ;) Durch das Umwandeln hast Du weder einen Vor-, noch einen Nachteil. Du machst Dir lediglich unnötig viel Arbeit, da die Schrift beim Tweenen automatisch umgewandelt wird...

Den Text durch kleine Bilder zu ersetzen ist keine schlechte Idee. Dann siehst Du zumindest, ob es am Text liegt. Nur vermute ich, dass dem nicht so ist, da der Film bei mir ja - wie gesagt - nicht ruckelt.

Interessanter wäre folgende Vorgehensweise:

- Öffne die Flash-Datei
- Wähle im Menü "Datei" => "Film exportieren"
- Exportiere den Film als QuickTime oder als AVI-Datei

Es wäre höchst interessant zu sehen, ob die Video-Datei Deiner Animation auch ruckelt, oder nicht... ;)
Signatur von »LapisInfernalis« Eine Milde Gabe...

Der Horizont vieler Menschen ist ein Kreis mit dem Radius Null - und das nennen sie ihren Standpunkt.

Albert Einstein (1879-1955)

A common mistake people make when trying to design something completely foolproof is to underestimate the ingenuity of complete fools.
Douglas Adams (1952-2001)

11

Donnerstag, 7. Juli 2005, 12:27

Ruckelproblem - in MOV kleiner

Hi Lapis,
wegen so unnötigen Dingen wie Geldverdienen musste ich eine kleine Pause einlegen, aber ich habe dennoch einiges probiert...

Den Text durch kleine Bilder zu ersetzen ist keine schlechte Idee. Dann siehst Du zumindest, ob es am Text liegt. Nur vermute ich, dass dem nicht so ist, da der Film bei mir ja - wie gesagt - nicht ruckelt.

Bereits bei der ersten Zeile musste ich den Versuch aufgeben, weil ich es nicht hinkriegte, die als Bild abgespeicherten Texte auf durchsichtigen Grund zu bringen. Das ist aber notwendig, weil sonst der Text auf weißen Streifen in die Bühne fahren würde - und so stehen bliebe.

Interessanter wäre folgende Vorgehensweise:
- Öffne die Flash-Datei
- Wähle im Menü "Datei" => "Film exportieren"
- Exportiere den Film als QuickTime oder als AVI-Datei
Es wäre höchst interessant zu sehen, ob die Video-Datei Deiner Animation auch ruckelt, oder nicht... ;)[/quote]


Das habe ich gemacht und das Ergebnis ist auf jeden Fall viel besser! Der Text läuft zügig rein, aber es gibt trotzdem noch ein paar Stellen, wo der Fluss abgebremst und ruckelig wird. Diese Stellen sind übrigens sowohl im Original FLA-Dokument als auch im SWF- und im MOV-Film stets an der selben Stelle. Nur unterschiedlich stark ausgeprägt. Ich habe nicht die geringste Erklärung dafür http://www.webstyleboard.de/wsb/images/n…ilies/irre.gif. Und du?

12

Donnerstag, 7. Juli 2005, 12:53

[q=toni-s]Bereits bei der ersten Zeile musste ich den Versuch aufgeben, weil ich es nicht hinkriegte, die als Bild abgespeicherten Texte auf durchsichtigen Grund zu bringen.Das ist aber notwendig, weil sonst der Text auf weißen Streifen in die Bühne fahren würde - und so stehen bliebe.[/q]
Welches Dateiformat hast Du denn für die Bilder gewählt? Setze den Text in PhotoShop auf eine transparente Ebene und speichere das Bild als PNG (24). Dann bleibt die Transparenz erhalten...

[q=toni-s][...] trotzdem noch ein paar Stellen, wo der Fluss abgebremst und ruckelig wird. Diese Stellen sind übrigens sowohl im Original FLA-Dokument als auch im SWF- und im MOV-Film stets an der selben Stelle. Nur unterschiedlich stark ausgeprägt. Ich habe nicht die geringste Erklärung dafür. Und du?[/q]
Mmmmh... Das ist echt misteriös... Kannst Du die MOV-Datei mal auf Deinen Server laden, so dass man sich den Film mal herunterladen und ansehen kann?

So langsam aber sicher beschleicht mich das Gefühl, dass es echt mit Deiner Flash-Version / Betriebssystem zu tun hat...

Wenn Du möchtest, kannst Du mir die FLA-Datei mal zumailen (lapisinfernalis@webstyleboard.de)... Dann sehe ich mir die Datei mal direkt an, und erstelle auch mal einen Film daraus. Diesen solltest Du Dir dann mal auf Deinem Rechner ansehen, und beobachten, ob es Unterschiede zwischen Deinem und meinem Film gibt...
Signatur von »LapisInfernalis« Eine Milde Gabe...

Der Horizont vieler Menschen ist ein Kreis mit dem Radius Null - und das nennen sie ihren Standpunkt.

Albert Einstein (1879-1955)

A common mistake people make when trying to design something completely foolproof is to underestimate the ingenuity of complete fools.
Douglas Adams (1952-2001)

13

Donnerstag, 7. Juli 2005, 13:22

Zitat von »LapisInfernalis«


So langsam aber sicher beschleicht mich das Gefühl, dass es echt mit Deiner Flash-Version / Betriebssystem zu tun hat...

ich denke, dass dies wohl so ist. scheinbar laufen die mehreren Tweens so ungünstig, dass sie sich am ende gegenseitig die Leistung wechnehmen. Wenn man nämlich den Film per Button stoppt (also die Tweens im Hauptfenster stoppt), dann laufen die Tweens in den beiden obrigen Felder sofort wieder flüssig. Möglichweise hast du einfach stellenweise ein "Tween-Overload" :rolleyes:

mein System: PIII , 500 Mhz und 350 MB Ram
klar das Lapis mit seiner HighEnd-Kiste da kein Problem hat ... ;)
Signatur von »TheNobody Style«

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »TheNobody Style« (7. Juli 2005, 13:28)


14

Dienstag, 12. Juli 2005, 18:55

So... Ich hatte nun endlich die Gelegenheit, mir Deine FLA-Datei mal en detail anzusehen...

Eines Vorweg: An der Datei selbst kann es eigentlich nicht liegen:

a) die Zeitleiste ist aufgeräumt
b) es kommen nur Vektordaten zum Einsatz
c) maximal kommen elf Tweens gleichzeitig zum Einsatz

Wenn Du Dir die Datei mal in der Vorschau ansiehst (STRG + Enter) siehst Du im oberen Bildschirmbereich eine Übersicht über das Datenaufkommen der Datei, Bild für Bild.

Dort wirst Du sehen, dass es an keiner Stelle zu großen Datenmengen kommt. Die Datenrate liegt mit 2.400 Byte/Sekunde in einem sehr kleinen Bereich. Sie sollte auch für langsamere Rechner kein Problem darstellen...

Einen Verdacht habe ich jedoch... Die Schrift...

Als ich die Datei das erste mal geöffnet habe, wurde die Copperplate Gothic durch die Arial ersetzt, da die verwendete Schrift nicht installiert war.

Eine Vorschau mit der Ersatz-Schrift ließ kein Ruckeln erkennen. Erst nachdem ich die Originalschrift installiert und ausgetauscht habe, begann das Ruckeln...

Das machte mich neugierig. Doch zunächst ein kleiner Exkurs in Sachen Vektorgrafik...

Vektorgrafik unterscheidet sich ja von Pixelbildern darin, dass die Inhalte durch mathematische Funktionen beschrieben sind, und nicht aus einzelnen Bildpunkten bestehen. Darin liegen zwei Vorteile:

a) geringere Datenmenge, da nur die Koordinaten und Eigenschaften wir Füllung usw. gespeichert werden müssen

b) die Grafiken sind quasi grenzenlos und ohne Qualitätsverlust skalierbar

Soweit die Theorie. Allerdings wird es auch bei Vektorgrafiken problematisch, wenn diese sehr komplex werden.

Daher habe ich mir den Ausdruck "Kommunale Einrichtungen" mal als Beispiel genommen, und ihn in zwei Schriften genauer unter die Lupe genommen: einmal in der von Dir verwendeten Copperplate Gothic und einmal in einer "normalen" Arial.

Das Ergebnis: Durch die feinen Serifen (kleine "Füßchen" an den Ecken und Enden der Buchstaben) ist die Anzahl an Knotenpunkten der Vektorlinien weitaus komplexer, als von "einfachen" Schriften...

Während die Arial weniger als 300 Knotenpunkte auf die "Waage" brachte, lieferte die Copperplate mit fast 700 Knotenpunkten mehr als das Doppelte "Gewicht".

Laufen nun mehrere Tweens parallel, so kommen schnell tausende von Knotenpunkten zusammen, die berechnet werden wollen. Und laufen dann auch noch mehrere Filme parallel in einem Fenster ab, so scheint dies die Flash Engine schlichtweg ein wenig zu überfordern...

Das bedeutet, dass Du im Prinzip zwei Möglichkeiten hast:

a) Eine andere Schrift verwenden

b) Die Schrift in Photoshop setzen und als PNG speichern, um die Transparenz zu erhalten. Es wäre interessant zu sehen, ob dies die Performance günstig beeinflusst...

Soweit erst einmal von mir...

Ich hoffe, ein wenig geholfen zu haben... ;)

LapisInfernalis
Signatur von »LapisInfernalis« Eine Milde Gabe...

Der Horizont vieler Menschen ist ein Kreis mit dem Radius Null - und das nennen sie ihren Standpunkt.

Albert Einstein (1879-1955)

A common mistake people make when trying to design something completely foolproof is to underestimate the ingenuity of complete fools.
Douglas Adams (1952-2001)

15

Mittwoch, 20. Juli 2005, 18:01

Ruckelursache gefunden - Grund (noch) nicht erkannt

Hi Lapis,
ich bin der Ruckelei endlich auf die Schliche gekommen. Alle Meinungen, woher sie kommen könnte, stellten sich damit als gut gemeint, aber doch unrichtig heraus.
Zuerst nahm ich in von allen Textebenen die Alpha-Tweens heraus, doch ohne Erfolg.
Dann schrieb ich alle Texte in Photoshop neu und speicherte sie als *.png ab. Leider ließ sich das Ruckeln auch so nicht abstellen.
Dann wurde mir die Sache zu blöd und ich löschte Ebene für Ebene weg, bis nur noch die letzte Zeile übrigblieb. Jetzt rate mal, was passierte: Nix!!!! Das Ruckeln blieb auch auf der zuletzt übrigen Textzeile erhalten. Sicherheitshalber löschte ich diese ebenfalls und nahm dafür eine andere wieder herein, aber weiterhin ohne Erfolg.
So, und jetzt waren natürlich nur noch die 3 Hintergrundbilder übrig. Ganz einfache JPGs ohne Schnickschnack. Ich löschte sie erst mal nicht, sondern blendete sie nacheinander nur mal aus. Und da haut's doch glatt dem Fass den Boden aus: Mit jeder ausgeblendeten Ebene wurde die Ruckelei besser und als nur noch ein weißer Hintergrund da war, liefen die Textzeilen wie mit Schmierseife eingerieben!
Wehe dem, der es wagt, mich zu fragen, warum ich die Hintergründe nicht gleich weggelassen habe http://www.webstyleboard.de/wsb/images/n…ilies/angry.gif

Ich konnte jetzt zwar das Ruckelproblem alleine lösen, aber ohne den Hintergrund ist die Animation nur noch halb so schön.http://www.webstyleboard.de/wsb/images/n…milies/irre.gif

Nun wäre ich neugierig, was die Experten zum Thema zu sagen haben. Was mich betrifft, so denke ich, dass ich am Ende meines Lateins angelangt bin.http://www.webstyleboard.de/wsb/images/n…s/undecided.gif
Ciao,
Toni

16

Mittwoch, 20. Juli 2005, 19:48

Hi toni-s,

ich habe mal die Hintergrundbilder in den Dateien, die ich von Dir habe gelöscht. Ich beobachte das gleiche Phänomen... Merkwürdig.

Leider kann ich die Bilder nicht bearbeiten, da die Originale ja nicht mit dabei sind. Wie groß sind die Bilder im Original? Welche Auflösung haben sie?

Eine ganz andere Frage am Rande: Wieso erscheinen die Smileys bei Dir als Hyperlink, anstatt als Grafik?

Grüße

LapisInfernalis
Signatur von »LapisInfernalis« Eine Milde Gabe...

Der Horizont vieler Menschen ist ein Kreis mit dem Radius Null - und das nennen sie ihren Standpunkt.

Albert Einstein (1879-1955)

A common mistake people make when trying to design something completely foolproof is to underestimate the ingenuity of complete fools.
Douglas Adams (1952-2001)

17

Donnerstag, 21. Juli 2005, 09:38

ruckelursache gefunden - Grund (noch) nicht erkannt

Hallo Lapis,
leider kam ich noch nicht dazu, die Hintergrundbilder genauer zu durchleuchten. Jedenfalls weiß ich, dass sie genau aufs Pixel die richtige Größe haben. Ich habe den Verdacht, dass die Herkunft der Bilder mit dem Phänomen zu tun haben. Ich machte damals einen Screenshot von meinem Bildschirmhintergrund, färbte ihn mit Photoshop um und speicherte ihn mehrfach ab. Aber wie gesagt, ich prüfe das nochmals genauer nach.
Wieso die Smilies nicht erscheinen, liegt vielleicht an der Handhabung. Wahrscheinlich habe ich das als Mac-Man so wie immer gemacht: packen, reinziehen, fertig. Wie ich es aber richtig machen muss, weiß ich im Moment auch noch nicht. Bin gerade auf dem Sprung zu einem Termin...
Ciao
Toni

18

Donnerstag, 21. Juli 2005, 09:46

Hallo Toni!

Das mit den Bildern ist bestimmt interessant nachzuvollziehen. Es wäre nett, wenn Du uns diesbezüglich auf dem Laufenden hälst.

Was die Smileys angeht: Per Drag & Drop erhälst Du in der Tat nur den Link... Um die Smileys direkt in den Text einzufügen genügt es, wenn Du Sie anklickst. An der aktuellen Cursorpostion wird dann der "Code" für den Smiley eingefügt, welcher dann beim posten durch die Smileygrafik ersetzt wird.

So wird aus Semikolon / runder Klammer dieser Smiley: ;)

Im Laufe der Zeit lernst Du dann die Smileys automatisch und schreibst sie direkt in den Text. Geht schneller...

Viel Spaß/Erfolg bei Deinem Termin und bis später

LapisInfernalis
Signatur von »LapisInfernalis« Eine Milde Gabe...

Der Horizont vieler Menschen ist ein Kreis mit dem Radius Null - und das nennen sie ihren Standpunkt.

Albert Einstein (1879-1955)

A common mistake people make when trying to design something completely foolproof is to underestimate the ingenuity of complete fools.
Douglas Adams (1952-2001)

19

Donnerstag, 27. Juli 2006, 17:37

RE: Preloader in % und Bytes für Flash MX

Hi,

Dein Tutorial ist super erklärt ! Danke :-)
Aba irgend was mach ich trotzdem Falsch.
-------------------------------------------------------

**Error** Scene=Scene 1, layer=Layer 1, frame=1:Line 1: Syntax error.
bytes_gesamt = _root.getBytesTotal() add " Bytes gesamt";

**Error** Scene=Scene 1, layer=Layer 1, frame=1:Line 2: Syntax error.
bytes_geladen = _root.getBytesLoaded() add " Bytes geladen";

**Error** Scene=Scene 1, layer=Layer 1, frame=1:Line 3: Syntax error.
prozent = int(_root.getBytesLoaded()*100/_root.getBytesTotal()) add " Prozent";

Total ActionScript Errors: 3 Reported Errors:
-------------------------------------------------------
Diese Fehlermeldung bekomme ich jedesmal.
Was mach ich falsch?
Ich habe 100% alles richtig beschriftet.

Gruß

Leo

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »leonid1984« (27. Juli 2006, 17:38)


20

Donnerstag, 27. Juli 2006, 17:48

könntenst du mal den gesamten Code hier posten?
Signatur von »TheNobody Style«

Zurzeit ist neben dir 1 Benutzer in diesem Thema unterwegs:

1 Besucher